Airsoft Ohio Forums

Airsoft Ohio Forums (http://www.airsoftohio.com/forums/index.php)
-   Electric Guns (AEG) (http://www.airsoftohio.com/forums/forumdisplay.php?f=23)
-   -   PTW Magazine problem (http://www.airsoftohio.com/forums/showthread.php?t=34994)

Cytin 06-02-2011 06:38 PM

PTW Magazine problem
 
I have been using my PTW for about a month, and I have been encountering a problem with the 120rd magazines. They are systema brand mags.

Here is the issue: If I have shot some of the bbs in the mag and then remove it, about 30 bbs will also come out of the mag. My friend also has the same issue with his magazines. It is obviously not the gun, because the 30rd magazines work without a single problem. I believe it has something to do with the 2 things on top of the mag, holding the bbs in the mag. Also one of the 2 things on the mag will sometimes get stuck and I will have to fiddle with it to get it unstuck.

There is probably an easy fix to this, any help is appreciated.

Sorry if I am not using correct terminology for the parts, I don't know the name :)

Firefox 06-02-2011 06:49 PM

I've ran into this problem with my PTW mags before too. What I did to remedy the problem is as follows:

-remove magazine from metal casing
-remove the two black detents from the plastic magazine
-with a very fine grit sand paper sand down all sides of the follower just a little bit to allow free movement inside the magazine body and apply a little silicon oil.
-reassemble magazine and test, repeat procedure if needed.

Good luck!

Cytin 06-02-2011 06:55 PM

Quote:

Originally Posted by Firefox (Post 326414)
I've ran into this problem with my PTW mags before too. What I did to remedy the problem is as follows:

-remove magazine from metal casing
-remove the two black detents from the plastic magazine
-with a very fine grit sand paper sand down all sides of the follower just a little bit to allow free movement inside the magazine body and apply a little silicon oil.
-reassemble magazine and test, repeat procedure if needed.

Good luck!

Thank you I will try this soon. :)

UrbanMarine 06-02-2011 07:28 PM

If you can't get them to work with what Firefox said, RMA them to Zshot and I'll get them working.


All times are GMT -5. The time now is 07:02 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2005 - 2009 Airsoft Ohio